[Synthetics] Health Check | www.expitaly.it is DOWN
Incident Report for eXp Service Status
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 09:31 UTC
Identified
[Synthetics] Health Check | www.expitaly.it is DOWN. We are currently working to resolve the issue.
Posted Apr 25, 2024 - 09:30 UTC