[Synthetics] Health Check | wa.exprealty.com is DOWN
Incident Report for eXp Service Status
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 19:18 UTC
Identified
[Synthetics] Health Check | wa.exprealty.com is DOWN. We are currently working to resolve the issue.
Posted Apr 26, 2024 - 18:30 UTC