[Synthetics] Health Check | irss.expenterprise.com is DOWN

Incident Report for eXp Service Status

Resolved

This incident has been resolved.
Posted May 07, 2025 - 18:39 UTC

Identified

[Synthetics] Health Check | irss.expenterprise.com is DOWN. We are currently working to resolve the issue.
Posted May 07, 2025 - 18:35 UTC