[Synthetics] Health Check | trx.exp-uk.co.uk is DOWN

Incident Report for eXp Service Status

Resolved

This incident has been resolved.
Posted Feb 15, 2026 - 00:00 UTC

Identified

[Synthetics] Health Check | trx.exp-uk.co.uk is DOWN. We are currently working to resolve the issue.
Posted Feb 14, 2026 - 23:56 UTC